I've updated to 10.4.10 and now bruCLONE says that it can't run on versions prior to 10.3.9. What happened?

The release of bruCLONE v1.1.0 fixes the following issues:
To download this update, visit the bruCLONE Updates page.