Does bruCLONE work on Mac OS X 10.5 (Leopard)?

We are pleased to announce that our BRU Server™, BRU LE™, and bruCLONE™ solutions are Leopard compatible and have been fully tested. Purchases of new Macintosh 10.5 systems can be made with the confidence of knowing BRU is available to properly backup and restore systems.